SCADA Vulnerabilities & Exposures (SVE)

CRITIFENCE® SCADA Vulnerabilities and Exposures Database (SVE)

[SVE-995336515] Lynxspring JENEsys BAS Bridge Vulnerabilities

Date Type Platform Author EDB-ID CVE-ID OSVDB-ID Download App SIS Signature
2016-11-15OtherLynxspringICS-CERTN/ACVE-2016-8357 CVE-2016-8361 CVE-2016-8378 CVE-2016-8369 N/AN/AN/A

Source

						
							
								
#
# Lynxspring JENEsys BAS Bridge Vulnerabilities
#


### OVERVIEW

Independent researcher Maxim Rupp has identified several vulnerabilities in Lynxspring's JENEsys BAS Bridge application. Lynxspring has discontinued the BAS Bridge application and recommends that users upgrade to the Onyxx Bridge product.
These vulnerabilities could be exploited remotely.



### AFFECTED PRODUCTS

The following BAS Bridge versions are affected:
 BAS Bridge versions 1.1.8 and older.



### IMPACT

Attackers are able to change permissions and access controls and also gain access to the system. They are also able to retrieve credentials. The application transmits or stores authentication credentials and uses an insecure method that is susceptible to unauthorized interception and/or retrieval. The application also does not properly verify requests allowing attackers to use a cross-site request forgery.
Impact to individual organizations depends on many factors that are unique to each organization. NCCIC/ICS-CERT recommends that organizations evaluate the impact of these vulnerabilities based on their operational environment, architecture, and product implementation.



### BACKGROUND

Lynxspring is a US-based company that maintains offices in Lee's Summit, Missouri.
The affected product, BAS Bridge, is a web-based SCADA system. According to Lynxspring, BAS Server is deployed across several sectors including Commercial Facilities, Critical Manufacturing, Energy, Water and Wastewater Systems, and others. Lynxspring estimates that this product is used primarily in the United States.



### VULNERABILITY CHARACTERIZATION

# VULNERABILITY OVERVIEW

PERMISSIONS, PRIVILEGES, AND ACCESS CONTROLSa
A user with read-only access can send commands to the software and the application will accept those commands. This would allow an attacker with read-only access to make changes within the application.
CVE-2016-8357b has been assigned to this vulnerability. A CVSS v3 base score of 7.1 has been assigned; the CVSS vector string is (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N)

MISSING AUTHENTICATION FOR CRITICAL FUNCTIONd
The application uses a hard-coded username with no password allowing an attacker into the system without authentication.
CVE-2016-8361e has been assigned to this vulnerability. A CVSS v3 base score of 8.6 has been assigned; the CVSS vector string is (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L)

INSUFFICIENTLY PROTECTED CREDENTIALSg
The application's database lacks sufficient safeguards for protecting credentials.
CVE-2016-8378h has been assigned to this vulnerability. A CVSS v3 base score of 9.8 has been assigned; the CVSS vector string is (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

CROSS-SITE REQUEST FORGERY (CSRF)j
The application does not sufficiently verify if a request was intentionally provided by the user who submitted the request.
CVE-2016-8369k has been assigned to this vulnerability. A CVSS v3 base score of 9.8 has  been assigned; the CVSS vector string is (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)




### VULNERABILITY DETAILS

# EXPLOITABILITY

These vulnerabilities could be exploited remotely.



# EXISTENCE OF EXPLOIT

No known public exploits specifically target these vulnerabilities.



# DIFFICULTY

An attacker with a low skill would be able to exploit these vulnerabilities.



### MITIGATION

Lynxspring recommends replacing existing BAS Bridge installations with the Onyxx Bridge product
The Onyxx Bridge product has been tested by Lynxspring to be free of the existing vulnerabilities in the old product
BAS Bridge has been end of life since 2014 and no further updates will be issued.