SCADA Vulnerabilities & Exposures (SVE)

CRITIFENCE® SCADA Vulnerabilities and Exposures Database (SVE)

[SVE-293198036] ABB DataManagerPro Credential Management Vulnerability

Date Type Platform Author EDB-ID CVE-ID OSVDB-ID Download App SIS Signature
2016-09-15SOFTWAREABB DataManagerProAndrea MicalizziN/A2016-4526N/AN/AN/A

Source

						
							
								
#
# ABB DataManagerPro Credential Management Vulnerability
#


### OVERVIEW

NCCIC/ICS-CERT received a report from Trend Micro's Zero Day Initiative (ZDI) concerning a credential management vulnerability in ABB's DataManagerPro application. Security researcher Andrea Micalizzi reported this vulnerability to ZDI. ABB has produced a new version to mitigate this vulnerability.



### AFFECTED PRODUCTS

ABB reports that the vulnerability affects the following versions of DataManagerPro:

DataManagerPro, all versions: 1.0.0 to 1.7.0






### IMPACT

An attacker who successfully exploits this vulnerability could insert and run arbitrary code on a computer where the affected product is used.

Impact to individual organizations depends on many factors that are unique to each organization. ICS-CERT recommends that organizations evaluate the impact of this vulnerability based on their operational environment, architecture, and product implementation.






### BACKGROUND

ABB is a Switzerland-based company that maintains offices in several countries around the world.

The affected product, DataManagerPro, is data analysis software. According to ABB, DataManagerPro is deployed in the Energy, Food and Agriculture, and Water and Wastewater Systems sectors. ABB estimates that this product is used worldwide.





### VULNERABILITY CHARACTERIZATION


# VULNERABILITY OVERVIEW


UNCONTROLLED SEARCH PATH ELEMENT

An authenticated user may swap DLLs in the package directory to elevate permissions to administrator.

CVE-2016-4526 has been assigned to this vulnerability. A CVSS v3 base score of 7.2 has been calculated; the CVSS vector string is (AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H).






### VULNERABILITY DETAILS


# EXPLOITABILITY

This vulnerability is not exploitable remotely and cannot be exploited without user interaction.


# EXISTENCE OF EXPLOIT

No known public exploits specifically target this vulnerability.


# DIFFICULTY

An attacker with low skill would be able to exploit this vulnerability.





### MITIGATION

ABB has produced a new version (Version 1.7.1) to mitigate this vulnerability. ABB recommends that users apply the update at their earliest convenience. Users may find more information in ABB's security advisory (ABB-VU-BUMP-089290) located on its web site at the following location:

https://library.e.abb.com/public/93e52dbfd6ab4f64aa435973ccf1b6e2/9ADB005557_ABB_SoftwareVulnerabilityHandlingAdvisory_DMPro.pdf

ABB recommends security practices and firewall configurations to help protect systems from attacks that originate from outside the network. 
Such practices include:

* Carefully inspect any files transferred between computers, including scanning them with up-to-date antivirus software, so that only legitimate files may be transferred.

* User account management, appropriate authentificaton and permission management using the principle of least privilege.

More information on recommended practices can be found in the following ABB document:
3BSE032547, Whitepaper - Security for Industrial Automation and Control Systems